TYPO3 – tt_news mit real_url

Wenn Ihr real_url mit tt_news verwenden wollt, dann müsst Ihr diese TypoScript Befehle unbedingt mit einbinden:


plugin.tt_news.useHRDatesSingle = 1
plugin.tt_news.useHRDatesSingleWithoutDay = 0
plugin.tt_news.dontUseBackPid = 1
plugin.tt_news.useHRDates = 1

[ad#posting]

 

Hier noch meine: realurl_conf.php


<?php
$TYPO3_CONF_VARS['EXTCONF']['realurl']['_DEFAULT'] = array(

'init' => array(
'useCHashCache' => '0',
'enableCHashCache' => 1,
'respectSimulateStaticURLs' => 'TRUE',
'appendMissingSlash' => 'ifNotFile',
'enableUrlDecodeCache' => '1',
'enableUrlEncodeCache' => '1',
),

'preVars' => array(
array(
'GETvar' => 'no_cache',
'valueMap' => array(
'no_cache' => 1,
'nc' => 1,
),
'noMatch' => 'bypass',
),
array(
'GETvar' => 'L',
'valueMap' => array(
'de' => '0',
'en' => '1',
),
'noMatch' => 'bypass',
),
),

'pagePath' => array(
'type' => 'user',
'userFunc' => 'EXT:realurl/class.tx_realurl_advanced.php:&tx_realurl_advanced->main',
'spaceCharacter' => '-',
'segTitleFieldList' => 'alias,tx_realurl_pathsegment,nav_title,title',
'languageGetVar' => 'L',
'expireDays' => 1,
'disablePathCache' => 1,
'rootpage_id' => 1,
),

'fileName' => array(
'defaultToHTMLsuffixOnPrev' => '.html',
'index' => array(
'rss.xml' => array(
'keyValues' => array(
'type' => 100,
),
),
'rss091.xml' => array(
'keyValues' => array(
'type' => 101,
),
),
'rdf.xml' => array(
'keyValues' => array(
'type' => 102,
),
),
'atom.xml' => array(
'keyValues' => array(
'type' => 103,
),
),
),
),

'postVarSets' => array(
'_DEFAULT' => array(

'browse' => array(
array( 'GETvar' => 'tx_ttnews[pointer]', 'valueMap' => array('weiter' => '1','weiter' => '2',)),),

// news kategorien

'kategorie' => array (
array( 'GETvar' => 'tx_ttnews[cat]', 'lookUpTable' => array('table' => 'tt_news_cat', 'id_field' => 'uid', 'alias_field' => 'title', 'addWhereClause' => ' AND NOT deleted', 'useUniqueCache' => 1, 'useUniqueCache_conf' => array( 'strtolower' => 1, 'spaceCharacter' => '-', ),),),),

// news artikel

'datum' => array(
array('GETvar' => 'tx_ttnews[year]' , ),

array('GETvar' => 'tx_ttnews[month]' , ),
array('GETvar' => 'tx_ttnews[day]' , ),
array('GETvar' => 'tx_ttnews[tt_news]','lookUpTable' => array( 'table' => 'tt_news', 'id_field' => 'uid', 'alias_field' => 'title', 'addWhereClause' => ' AND NOT deleted', 'useUniqueCache' => 1, 'useUniqueCache_conf' => array( 'strtolower' => 1, 'spaceCharacter' => '-', ),),),),

),),
);

?>

Eure Meinung zu dem Artikel ist gefragt! Schreibt mir ein Kommentar

Hat Euch der Artikel weitergeholfen oder gefallen?
Ich freue mich auf einen Blick auf meine Amazon-Wunschliste. Vielen Dank!

Hat Euch der Artikel weitergeholfen oder gefallen? Ich freue mich auf einen Blick auf meine Amazon-Wunschliste. Vielen Dank!Ich bin freiberuflicher TYPO3-Entwickler, Web-Entwickler und Frontend-Entwickler. Ich arbeite im und für das Web etwas mehr als 12 Jahre. Mehr Infos zu der TYPO3 Internetagentur - INGENIUMDESIGN.

Leave a Reply

4 Kommentare

  1. Vielen Dank für Deinen Beitrag!
    Hat auf anhieb funktioniert, im gegensatz zu den anderen Anleitungen die ich gefunden habe.
    Aufwand ca. 2 Min. 😉

    Ich verwende:
    TYPO3 CMS 6.2.9
    tt_news 3.6.0
    Real Url 1.12.8

    Grüsse Christian Siegmann

  2. Tom

    Hey, danke für die Anleitung, aber ich kriege das einfach nicht zum Laufen. Hab alles nach der Anleitung gemacht, auch genau deine RealURL-Config übernommen (außer Rootpage natürlich), aber es will einfach nicht funktionieren. Hab schon alle Tabellen vom Installtool checken lassen, das Temp-Verzeichnis und generell Caches geleert, aber es tut sich nichts. Hat irgendjemand vielleicht noch eine Idee woran es sonst liegen kann? Bin für jede Hilfe dankbar!!
    T3: 6.2.9
    RealURL 1.12.8
    tt_news 3.6.0

    VG Thomas

  3. Danke für das Script! Endlich läuft realURL bei tt_news unter TYPO3 6.2.

  4. Danke für die Anleitung! Geht das auch ohne /datum/03-05-10 ?
    danke!

Next ArticleTYPO3 - 4.2.10 Update