TYPO3 – powermail ohne jquery laden

Einige von Euch haben bestimmt das gleiche Problem und möchten gerne die TYPO3 Extension Powermail ohne Jquery laden. Ich binde zum Beispiel jquery und JqueryUi selbst in TYPO3 ein.

So könnt Ihr via TYPOScript jquery/jqueryui nicht mit laden:

############################
# JavaScript and CSS section
############################
page {
  # Inlude JavaScript files
  includeJSFooterlibs {
    powermailJQuery =
    powermailJQuery.external = 0
    powermailJQueryUi =
    powermailJQueryUi.external = 0
    powermailJQueryUiDatepicker = EXT:powermail/Resources/Public/Js/jquery.ui.datepicker.min.js
    powermailJQueryFormValidationLanguage = EXT:powermail/Resources/Public/Js/jquery.validationEngine-en.js
    powermailJQueryFormValidation = EXT:powermail/Resources/Public/Js/jquery.validationEngine.js
    powermailJQueryTabs = EXT:powermail/Resources/Public/Js/tabs.js
  }

  includeJSFooter {
    powermailForm = EXT:powermail/Resources/Public/Js/form.js
  }

  # Include CSS files
  includeCSS {
    powermailJQueryUiTheme = EXT:powermail/Resources/Public/Css/jquery.ui.theme.css
    powermailJQueryUiDatepicker = EXT:powermail/Resources/Public/Css/jquery.ui.datepicker.css
  }
}

So sieht mein TYPOSCRIPT Code aus. Natürlich müsst Ihr nicht alles mitladen.

Eure Meinung zu dem Artikel ist gefragt! Schreibt mir ein Kommentar

Hat Euch der Artikel weitergeholfen oder gefallen?
Ich freue mich auf einen Blick auf meine Amazon-Wunschliste. Vielen Dank!

Hat Euch der Artikel weitergeholfen oder gefallen? Ich freue mich auf einen Blick auf meine Amazon-Wunschliste. Vielen Dank!Ich bin freiberuflicher TYPO3-Entwickler, Web-Entwickler und Frontend-Entwickler. Ich arbeite im und für das Web etwas mehr als 12 Jahre. Mehr Infos zu der TYPO3 Internetagentur - INGENIUMDESIGN.

Leave a Reply

1 Kommentar

  1. Wer kein jQuery laden möchte, der kann auch auf die Extension Formhandler umsteigen. Ebenfalls ein mächtiges Werkzeug, allerdings für Redakteuere nicht so komfortabel wie Powermail

Next ArticleTYPO3 4.6.xx und 4.7.xx andere Version der Erweiterungen installieren